正在加载中……
最新消息:欢迎大家访问,导航分类不完善,如果找不到自己想要的文章,可以通过【关键词】来进行搜索,^_^!

[解决方法]Python 3.6.4 使用pip安装PyYAML出错

python REKFAN.COM 238浏览 0评论

更多


Installing collected packages: scipy, pyyaml, keras
  Running setup.py install for pyyaml ... error
Exception:
Traceback (most recent call last):
  File "c:usersmyjacappdatalocalprogramspythonpython36-32libsite-packagespipcompat__init__.py", line 73, in console_to_str
    return s.decode(sys.__stdout__.encoding)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xce in position 68: invalid continuation byte
 
During handling of the above exception, another exception occurred:
 
Traceback (most recent call last):
 
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xce in position 68: invalid continuation byte

解决方案
 
使用chcp命令,更改代码页为65001(UTF-8)再执行pip安装命令即可。
 
 
另外提供一些chcp命令的参考:
 
chcp 65001  就是换成UTF-8代码页
chcp 936 可以换回默认的GBK
chcp 437 是美国英语
 
注:在命令行输入

转载请注明:|REKFAN|系统运维| » [解决方法]Python 3.6.4 使用pip安装PyYAML出错

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址