正在加载中……
最新消息:欢迎大家访问,导航分类不完善,如果找不到自己想要的文章,可以通过【关键词】来进行搜索,^_^!

禁止Linux ‘yum update’更新时升级内核的方法

Linux专题 REKFAN.COM 8869浏览 0评论

更多


引言:由于系统与硬件的兼容性问题,有可能升级内核后导致服务器不能正常启动,这是非常可怕的,没有特别的需要,建议不要随意升级内核。
 
CentOS使用yum update更新时不升级内核

cp /etc/yum.conf /etc/yum.confbak   #先备份一份配置文件 

方法一、修改yum的配置文件

vi /etc/yum.conf
在[main]的最后添加 exclude=kernel*

方法二、直接在yum的命令后面加上如下的参数:

yum --exclude=kernel* update

查看系统版本 cat /etc/issue
查看内核版本 uname -a

http://blog.rekfan.com/?p=140
 

转载请注明:|REKFAN|系统运维| » 禁止Linux ‘yum update’更新时升级内核的方法

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址